Yamaha Kodiak 700 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys im new to the site. I have a 2017 kodiak thats been giving me a few problems. I was outriding one day with some friends and everything was fine. out of nowhere it began sputtering and almost couldnt pull itself. i drove back to the trucks at about 7mph. we all tried to take a look at it and nobody could seem to figure anything out. i took it home and looked a little further but still nothing. the atv will idle all day long just fine but as soon as you give it any throttle, it skips and sputters and will eventually cut off. i took the throttle body off and cleaned everything i could and changed the spark plug. still nothing. can anybody give me any thought or maybe a possible fix???
 

·
Registered
Joined
·
761 Posts
I don't think the part is expensive but I would suggest having it tested to confirm if it is defective. Chasing a gremlin can get expensive if you just start replacing parts on assumption.
 

·
Registered
Joined
·
346 Posts
Not sure if the throttle pos sensor would need to be adjusted after being replaced, but that may need to be done at the dealership...just not sure on that one.
 

·
Super Moderator
Joined
·
1,881 Posts
A little bit late to the party but where have you been getting your fuel at when you fill it up? Is it gas out of a plastic/metal jug or directly from the filling station?

It almost sounds like a clogged fuel filter, but since we don't have fuel filters on these rigs it might be a problem with the fuel pump or the sock that they place on the pickup to substitute for a filter.
 
1 - 7 of 7 Posts
Top