Yamaha Kodiak 700 Forum banner

1 - 4 of 4 Posts

Registered
Joined
1 Posts
Discussion Starter #1
Hey guys need some help, noticed my 2016 kodiak fan wasnt kicking on and was getting hot. Tore into it and put 12 volts to the fan and comes on fine. Fuse was also good.So i back tracked to the switch where it goes into the block and jumped it. Fan came on and got dash lights. Thanking it might be the source i replaced it. And nothing lol so im looking for the location of the thermo switch and i cant find it. Any help would be great thanks!
 

Super Moderator
Joined
1,250 Posts
The coolant temperature sensor is located on the left hand side of the engine. It should be near the thermostat housing, just where I do not know I haven't had problems with mine. If you replace the sensor and there is still a problem the troubleshooting manual says that it may be a defective ECM
 

Super Moderator
Joined
1,250 Posts
Here is a video on a Grizzly on troubleshooting a cooling problem.

It shows the thermo switch on the left side of the radiator. I am sure that the Kodiak is the same.

 

Registered
Joined
473 Posts
You said "So i back tracked to the switch where it goes into the block and jumped it. Fan came on and got dash lights". In most cases that is where you need to concentrate your efforts, If the fan came on when you jumped it, the is the open in the circuit. With modern electronics, you might get some feedback from somewhere leading to a misdiagnosis. Good luck!
 
1 - 4 of 4 Posts
Top