Yamaha Kodiak 700 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Right now I'm running 8 x 16g greaseless weights from jbs, jbs milled sheave, stock belt and stock secondary spring. My top speed is around 25 mph right now, is that normal? It's almost like it doesn't want to shift into the secondary? Not sure exactly how much jbs milled off but I imagine a good bit. I know I'm rackin' heck of some rpms at 25mph.

Would a stiffer secondary help in my cause or do I have something not right? What is everyone's clutch setup and how well do they turn say 29.5 and what's your top speed?

I know I'd loose top speed with less gram weights but I didn't think 30+ mpg difference would of happened.

Anyways, thank you!
Cody
 

·
Registered
Joined
·
7 Posts
If you're running a milled sheave without any shims then you shouldn't be losing any top speed. It sounds like one or more of your clutch weights have fallen out of their slots. Check that first. A stiffer spring will give you a little more torque in the bottom end but won't affect top speed at all. And you won't lose any top speed with lighter weights, it'll just affect how quickly it "changes gears", longer upshifts than with heavier weights. Hope this helps! Cheers!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Alrighty! Thank you for your response. Yea I dunno, I went from 55-60ish stock to 28ish after the mill and weights. I'll look back in there and make sure the weights are right and see where that gets me. When I hit about 25mph i feel like i'ma blow the top out the ol kodiak with the rpms haha. I couldn't ever get it to upshift with the 16g weights.
 

·
Registered
Joined
·
129 Posts
Alrighty! Thank you for your response. Yea I dunno, I went from 55-60ish stock to 28ish after the mill and weights. I'll look back in there and make sure the weights are right and see where that gets me. When I hit about 25mph i feel like i'ma blow the top out the ol kodiak with the rpms haha. I couldn't ever get it to upshift with the 16g weights.
X2 on what KSNL85 said; make sure everything is correctly installed.
Almost sounds like you're in low gear... you're not in low gear, right?
 

·
Registered
Joined
·
31 Posts
I run a orange secondary spring and 20g weights both from epi. I run 26x12x12 radials all around and stand up easily and hit 59 top speed and it pulls hard whenever I need it.
 
1 - 5 of 5 Posts
Top