Yamaha Kodiak 700 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just replaced the headgasket on a Kodiak 700. Got it timed perfectly. torqued all bolts to what is specified in the manual. I go to start it and it feels like it can't get past the compression. Full charged battery jump box being used for power. Changed out the starter because thought it may be a weak starter but same issue. I can manually turn the engine over with a wrench just past compression them hit the starter button and she gets enough rotation to start. starts runs and sounds good. Shut her down then hit the button again and the same thing happens. So I believe the decomp on the cam is not opening. I have done the update so I know that's good. When I turn the engine over manually I can see that the decomp detent that hits the valve cap is supposed to twist to the flat spot when the cam turns over the valve cap but it does not twist. I can activate the decomp by hand I can even hold it open till it gets to the valve cap and see that that is the way it is supposed to go but on the next revolution without holding it open by hand it does the same thing and does not open. Any help would be greatly appreciated.
 

·
Registered
Joined
·
473 Posts
You sound very knowledgeable, so I will mention a few things, the first one is dumb and the second one is equally dumb, but here are the first two.

Is the battery good?

New starter might not be up to new torque.

last, question is, that if the first two are OK, then it likely is the decompression issue. I do think that valve clearance has a lot to do with that.

Good luck, and there are wiser answers coming shortly form the knowledgeable people!
 
1 - 2 of 2 Posts
Top